Error while installing a DBpedia mirror using the the Databus Docker images

Dear community,

for starting our GSoC project Modular DBpedia Chatbot I tried to set up a DBpedia mirror. I followed the description at GitHub - dbpedia/virtuoso-sparql-endpoint-quickstart: creates a docker image with Virtuoso preloaded with the latest DBpedia dataset and set up the .env file as described.

Unfortunately the installation failed with the Virtuoso error message Bad login after having downloaded the BZIP files. The error message is shown 60 times. Thereafter, the process stopped:

download_1  | Downloading file:
download_1  | File saved to /root/data/short-abstracts_lang=sv_uris=en_A833.ttl.bz2
download_1  | Downloading file:
download_1  | File saved to /root/data/short-abstracts_lang=uk_uris=en_198D.ttl.bz2
download_1  | Downloading file:
download_1  | File saved to /root/data/short-abstracts_lang=zh_uris=en_D2CC.ttl.bz2
download_1  | Done.
download_1  | Removing LOCK at /root/data
load_1      | will use ISQL port 1111 to connect
load_1      | [INFO] Waiting for store to come online (s)
store_1     | 01:34:10 Incorrect login for dba from IP []
load_1      | [ERROR] running the these commands in virtuoso:
load_1      | status();
load_1      | error code: 3
load_1      | output:
load_1      | 
load_1      | *** Error 28000: [Virtuoso Driver]CL034: Bad login
load_1      | at line 0 of Top-Level:
load_1      | .60

I also tried it with the default .env file. However, this has shown the same outcome.

In advance, thank you for your help.

I assume that you started the database once and then changed the password. You need to either restore the password you used when starting the database for the first time, or set a new password in config.env and delete the database folder (rm -rf virtuoso) and restart the compose setup.
A 3rd (but complicated) option is to change the password via isql (login with isql in the virtuoso container using the old password and set the one now used in config.env file). The 3rd option only makes sense if you don’t want to load the data again / delete the database.

1 Like

Hi Johannes,

you were correct, the reason was a changed .env file after a previous crash. I was not aware that the Docker image is reused if the import process has crashed.

Thank you very much.