Cannot open resource page using dbpedia dav package locally

Hi everyone,
I have already installed Virtuoso and already loaded the RDF triples successfully. And I found that I can serve the linked data of the loaded triples using the DBpedia virtuoso plugin found here virtuoso plugin. I also already installed the vad package (dbpedia_dav.vad) from there to my local virtuoso. But when I tried to access the resource Albert_Einstein using http://localhost:8890/resource/Albert_Einstein, I got this error:

Execution of “/DAV/VAD/dbpedia/description.vsp” failed.

SQL Error: 22026 SR352: Not enough arguments (only 2) for sprintf to match format '%s&output=application%2Frdf%2Bjson’

I don’t know what I did wrong and I can’t find any new answers on the Internet. I’m a newbie and any answer would be helpful. Thank you!

Please use https://github.com/dbpedia/Dockerized-DBpedia, then you have a virtuoso which is already setup and configured. You can also have a look into https://github.com/dbpedia/Dockerized-DBpedia/blob/master/dbpedia-loader/import.sh#L64 how this can be done.

Hi @jfrey thank you for replying my question and also I’m sorry for replying so late.
I already followed your suggestion by using dockerized DBpedia and I can run Virtuoso within the Docker image now. But I’m still confused on how to load my local N-Triple data to Virtuoso. Do you know a way to do this?

Yes. This will help you I think