A problem with retrieving classes' instances


I am a PhD student and I am working on building a dataset for my PhD research that requires some DBpedia’s class instances. However I came across a problem retrieving some of the classes instances where nothing is being retrieved.

This an example of a query that returns result https://api.triplydb.com/s/15PORDPP

this one does not https://api.triplydb.com/s/0H3TmeVP.

So I had this issue with some classes that are relevant to my method such as AcademicSubject, State, Province, District, Celebrity, Zoo, MovieDirector.

Thank you

It is because these classes that you tried do not have any instances. To solve the problem, first thing to try would be looking at the instances with specific type that you are trying - without names- to see if the problem occurs due to class type or name. I tried some of them the problem was a due to classes which don’t have instances. For instance, following zoo (http://dbpedia.org/page/Leipzig_Zoological_Garden) has other types defined in the data but not the type of Zoo. So when you search for it with Zoo type you can’t see it. As a result if you like you can select other types defined in the data and use them in your dataset or use other options such as skos concepts.